Error apache szModName : php5ts.dll

Apache a veces no arranca  tras haber actualizado algunas librerías o algún módulo y simplemente nos devuelve un error genérico referenciando a una dll, del tipo:

szAppName : httpd.exe     szAppVer : 2.2.16.0

szModName : php5ts.dll

szModVer : 5.2.14.14     offset : 000f36ec

En este caso el problema viene de las librerías del modulo de php para Apache  php5ts.dll,  aunque también es un fallo común a la hora de utilizar las librerías para mysql.  Todos estos problemas tienen una misma solución, simplemente la versión de nuestra dll no es compatible con las versiones del Apache.

En el error vemos que nos devuelve tamién la versión de la librería szModVer : 5.2.14.14  , debemos ver que esta coincida con nuestros módulos o usar siempre la última versión de las dll y el apache, para evitar líos mayores.

Si queremos saber que versión de dll estamos usando podemos ir al directorio donde se encuentra nuestra dll, en el caso más común para php  sería:

C:\Archivos de programa\Apache Software Foundation\Apache2.2\php

Vemos en el icono de nuestra dll justo debajo del nombre la version que usamos con el formato 5.3.2.0, si no la ves haz click derecho sobre la dll selecciona  propiedades y luego en versión, ahí aparece  podrás ver toda la información.

¿ Tienes más dudas sobre errores de Apache? –> COMENTA 🙂 .



Te puede interesar:

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *