Xampp no me lanza PHP

Bienvenidos  a VerTutoriales.com, en esta ocasión os traigo una posible solución a que no os arranque PHP, aunque veremos que no es el problema de arrancar PHP, sino de su configuración.

En mi caso antes de nada revisé la instalación, lo primero que debía de instalar al estar utilizando un sistema de microsoft, era la siguiente actualización de Visual Studio.

http://www.microsoft.com/es-es/download/confirmation.aspx?id=5582

Después de instalar y volver a probar, de instalar otros idiomas, cambiar la carpeta, etc, me dí cuenta de que el problema que estaba teniendo me sonaba de otras veces, sencillamente, PHP no estaba actuando como tal. Lo cual me llevó a pensar que posiblemente no fuera que PHP no estuviera bien instalado, sino que simplemente no estaba tomando el código bien.

En mi caso, en algunas partes del código utilizo la etiqueta <?php y en otras <? quizás por que varios han toqueteado el código y también por mi mismo que empecé programando con la etiqueta <? y poco a poco he ido cambiándola pero está claro que no está completamente migrado el código.

Esta explicación viene a decir que entréis en la configuración de php.ini, y busquéis “<?” aparecerá un texto como el siguiente:

; This directive determines whether or not PHP will recognize code between
; <? and ?> tags as PHP source which should be processed as such. It’s been
; recommended for several years that you not use the short tag “short cut” and
; instead to use the full <?php and ?> tag combination. With the wide spread use
; of XML and use of these tags by other languages, the server can become easily
; confused and end up parsing the wrong code in the wrong context. But because
; this short cut has been a feature for such a long time, it’s currently still
; supported for backwards compatibility, but we recommend you don’t use them.
; Default Value: On
; Development Value: Off
; Production Value: Off
; http://php.net/short-open-tag

Solo quedaría realizar un cambio en el PHP. ini:

short_open_tag = Off

pasarlo a

short_open_tag = On

Guardamos y reiniciamos apache para que tome la nueva configuración de PHP, si todo ha salido bien, ya tendréis funcionando vuestro servidor con PHP.

Espero que os sirva y os quite algo de tiempo de búsqueda y lo podáis solucionar de la misma manera.

Un saludo!

Te puede interesar:

2 comentarios

  • carlos k26 commented on 1 noviembre, 2012 Reply

    buenas noches , ya instale el paquete xampp pero no se donde programar . y practicar con los codigos . alguen me puede dar informacion sobre eso ?

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *