Actualizar ClamAv – WARNING: Your ClamAV installation is OUTDATED!

Bienvenidos a VerTutoriales.com, es posible que vuestro servidor de correo (postfix casi seguro) dejara de funcionar por culpa del antivirus, si fuera este el caso, tendreis instalado ClamAv Antivirus.

Llevaban tiempo avisando de que iban a vetar todas las versiones anteriores a la 0.95 y llegó el día y los que no estuvieran al tanto (como yo) se iban a quedar sin correo.

Si miramos en el log del correo

nano /var/log/mail.log

Nos devolvía:

LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later.

Viene a decir clarisimamente en la última línea que actualizaramos a la versión 0.95 o posterior.

Así que si ese problema te suena, vamos por partes y demos solución al tema.

1º Eliminamos la versión anterior:

aptitude remove clamav clamav-base clamav-daemon clamav-data  clamav-docs

(Con esta desinstalación se desinstalan dos paquetes que son dependendcias, así que volvemos a instalarlos para no liar el taco en el server)

aptitude install sharutils libclamav5

2º Incluir el repositorio volatile

Incluir el repositorio volatile en /etc/apt/sources.list:

nano /etc/apt/sources.list

y escribimos:

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

3º Actualizar la distribuición

Ya solo quedaría escribir un par de comandos más para lanzar las actualizaciones:

aptitude update
aptitude install clamav clamav-daemon

4º Reiniciamos el servicio

Ya solo quedaría reiniciar el servidor postfix

/etc/init.d/postfix restart

El servidor de correo esta activo.

Espero que le ayude a más de uno que como yo se quedó sin correo durante algún tiempo sin saber el por qué.

Un saludo!

Te puede interesar:

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *